SNMP supporting for WANPIPE
===========================

Author: Alex Feldman <al.feldman@sangoma.com>
Phone:	905.474.1990 x104



1. Current Wanpipe SNMP MIBs support Frame Relay, PPP, X.25 protocols.
   -------------------------------------------------------------------
   
	o Frame Relay protocol:
		frameRelayDTE.c
		frameRelayDTE.h
	o PPP protocol:
		ppp.c
		ppp.h
	o X.25 protocol:
		x25.c
		x25.h

2. Add Wanpipe MIB modules to UCS-SNMP agent:
   ------------------------------------------
   
	o Download the latest UCD-SNMP version from 
	  		https://sourceforge.net/projects/net-snmp.

	o Untar the snmp daemon in a temp directory
	  eg: 	cd /tmp
		tar xvfz <snmp-daemon-filename.tgz>

	o Copy the Wanpipe SNMP Mibs into the snmp daemon mib 
	  (agent/mibgroup) directory.
	  Wanpipe SNMP mibs are located in wanpipe/snmp directory.
	  eg:
	  	cd wanpipe/snmp
		cp *.c /tmp/<snmp-daemon-dir>/agent/mibgroup
		cp *.h /tmp/<snmp-daemon-dir>/agent/mibgroup
		
		
  	o Configure the SNMP Daemon source code to include the new 
 	  Wanpipe MIB modules:
	  eg:
          	cd /tmp/<snmp-daemon-dir>
          	./configure --with-mib-modules="<protocol mib> <protocol mib> ..."
		
		where <protocol mib>= [ frameRelayDTE | ppp | x25 ]

		thus, configure snmp daemon with frame relay mib:
		
			./configure --with-mib-modules="frameRelayDTE"
		
		or configure snmp daemon with all Wanpipe mibs:
	
			./configure --with-mib-modules="frameRelayDTE ppp x25"
     
     
	o The ./configure script should setup the SNMP Daemon environment to 
	  include the new Wanpipe Mibs.  
	  
	  For sanity sake :) double check that file 'agent/Makefile' contain 
	  references to included Wanpipe Mibs? 

	o Compile the suite (make) but don't install it yet. 
	  eg:	make
	  
	o Make utility should have compiled all mibs correctly, including the
	  new Wanpipe Mibs.
	  
	  For sanity sake :) double check that Wanpipe mibs have indeed 
	  been compiled in 'agent/mibgroup/' directory.  
	  Look for <protocol mib>.o  files ? 

	o Install the agent. (make install).
	  eg:	make install
	  

	o The new snmp daemon should be installed now and will have
	  new Wanpipe Mibs installed. 


3. How to use SNMP daemon:
   -----------------------

	Example:

	o Interfaces: To find the interface index for the network interface
	
		snmpgetnext localhost public interfaces \
			    interfaces.ifTable.ifEntry.ifDescr.<number>
	
	o Frame Relay: To receive DLCI number for network interface:
	
		snmpgetnext localhost public frameRelayDTE \
			    frameRelayDTE.frCircuiTable.frCircuitEntry.frCircuitDlci.<interface index>

	o Frame Relay: To receive status of Frame Relay interface:
		
		snmpgetnext localhost public frameRelayDTE \ 
			    frameRelayDTE.frDlcmiTable.frDlcmiEntry.frDlcmiStatus.<interface index>

	o Point-to-Point: To receive the number of received packet that have been discarded
		  	  because their length exceeded the MRU:

		snmpgetnext localhost public ppp \
			    ppp.pppLcp.pppLink.pppLinkStatusTable.ppplinkStatus.Entry.pppLinkStatusPacketTooLongs.<interface index>

	o X.25: To receive in which DCE/DTE mode the interface operates:

		snmpgetnext localhost public x25 \
			    x25.x25AdminTable.x25AdminEntry.x25AdminInterfaceMode.<interface index>


4. References
   ----------

   You can find complete list of all parameters for specific 
   protocol from following RFCs:
	
	o Frame Relay:		RFC1315.txt

	o Point-to-Point:	RFC1471.txt, RFC1472.txt, RFC1473.txt, RFC1474.txt

	o X.25:			RFC1382.txt

