Next Previous Contents

7. Drucken mit TurboPrint

Die TurboPrint Treiber werden in Ihrem Linux System vollkommen kompatibel zum vorbestehenden Treibersystem integriert (Einrichtung von Drucker Warteschlangen in in /etc/printcap). Somit funktioniert das Drucken mit TurboPrint genauso wie Sie es mit den anderen Linux Druckertreibern gewohnt sind.

Hinweis: Aktuelle Empfehlungen zu besonders geeigneten Tinten und Papieren für die verschiedenen Tintenstrahldrucker und Tips zu den richtigen Einstellungen in xtpconfig finden Sie auf unserer ZEDOnet Webseite www.zedonet.de.

7.1 Von der Shell aus drucken

Aus der Shell (Kommandozeilen-Eingabefenster) können Dateien mit dem "lpr" Kommando gedruckt werden:

lpr -Pprintername file(s)

Falls Sie CUPS installiert haben, gibt es folgenden alternativen Druckbefehl (je nach Linux-Distribution ist das "lpr"-Kommando nicht mehr vorhanden):

lp -d printername file(s)

Anstatt printer name geben Sie die Kurzbezeichnung der gewünschten Druckerkonfiguration ein, wie sie im xtpsetup Menü oder im Konfigurationsprogramm xtpconfig angezeigt wird. Die Voreinstellung für den ersten Drucker ist "tp0" - wenn Sie also eine Postscript-Datei namens "test.ps" drucken wollen, geben Sie ein:

lpr -Ptp0 test.ps

Sie können lpr auch an das Ende einer "Pipe" setzen - die Ausgabe eines vorangestellten Kommandos wird dann von lpr gedruckt. Auf diese Weise können Sie eine Datei vorher z.B. konvertieren oder umformatieren, bevor sie zum Drucker geschickt wird.

Beispiele:

a2ps --output=- textfile.txt | lpr -Ptp0

Eine ASCII Datei wird in eine Postscript-Datei mittels des "a2ps" Kommandos konvertiert und anschließend über lpr gedruckt.

Weitere Informationen über lpr erhalten Sie in der lpr-Man-Page (man lpr).

ASCII Dokumente formatieren

Um ASCII Text-Dateien in ein bestimmtes Layout zu bringen können Sie a2ps oder enscript direkt aufrufen. Hier einige Beispiele:

a2ps --portrait --borders=0 --columns=1 --no-header --printer=tp0 myfile.txt
enscript --portrait --columns=1 --no-header --printer=tp0 myfile.txt
druckt nur den text - keine Rahmen, eine Spalte, keine Header

a2ps --landscape --borders=1 --columns=2 --printer=tp0 myfile.txt
enscript --landscape --borders --columns=2 --printer=tp0 myfile.txt
druckt den Text im Querformat mit Rahmen, zwei Spalten pro Seite mit Header (Dateiname, Seitennummern).

Weitere Informationen über a2ps und enscript finden Sie in den entsprechenden Man-Pages (man a2ps, man enscript).

Welche Dateiformate können gedruckt werden?

Viele gängige Dateiformate wie z.B. Postscript, reine ASCII Dateien oder JPG-Grafiken werden von TurboPrint erkannt und können direkt aus der Kommandozeile gedruckt werden.

Verantwortlich für die korrekte Verarbeitung des Dateiformats ist der TurboPrint-Drucker-Filter "tpfilter". Er verwendet zur Erkennung des MIME Datei-Formates den Shell-Befehl "file".

Um zu sehen, welche Dateiformate derzeit unterstützt werden, und welche Kommandos zur Umwandlung verwendet werden, werfen Sie einen Blick in die tpfilter Man-Page (man tpfilter).

Falls ein Dateiformat von tpfilter nicht unterstützt wird (z.B. manche Grafikformate), muß es zuvor konvertiert werden.

7.2 Drucken aus Anwendungen

Intern sieht der Druckaufruf aus Anwendungen genauso aus wie das Drucken von der Kommandozeile: Das Anwendungsprogramm erzeugt eine temporäre Datei mit den zu druckenden Seiten (normalerweise im Postscript Format) und startet das lpr Kommando.

In den meisten Anwendungsprogrammen kann der Anwender entscheiden, ob ein anderes Druckkommando als lpr verwendet werden soll, und welche Parameter eingesetzt werden sollen (z.B. -Ptp0 zur Auswahl eines bestimmten Druckers).

Manche Anwendungsprogramme zeigen auch eine Liste der eingerichteten Drucker-Warteschlangen. Daraus wählen Sie einfach den gewünschten Drucker aus.

kde Drucker-Dialog

Beachten Sie: Für jeden von TurboPrint eingerichteten Drucker existiert auch zusätzlich eine "raw" Drucker-Warteschlange (z.B. "Epson_StylusColor680raw"). Diese wird normalerweise dazu verwendet, um von anderen Druckern über das Netzwerk auf den Drucker zuzugreifen. Wählen Sie die raw Warteschlange auf keinen Fall direkt an (erzeugt keine sinnvolle Druckausgabe).

Gimp

Klicken Sie das zu druckende Bild mit der rechten Maustaste an. Anschließend wählen Sie "File -> Print..." (Datei -> Drucken...). Im Feld "Printer Settings" (Drucker Einstellungen), Auswahlfeld "Printer" (Drucker), wählen Sie die Kurzbezeichnung Ihrer Druckerkonfiguration. Setzen Sie "Media Size" (Mediengröße) auf die gewählte Papiergröße.

gimp - Druck-Dialog

Klicken Sie jetzt auf den "Setup"-Schalter (Einrichten).

gimp - Setup Dialog

Wählen Sie "PostScript Level 2" als Druckertreiber. Auf keinen Fall einen herstellerspezifischen Treiber wählen (Epson / HP / ...)! Das Druck-Kommando der Voreinstellung muß leicht abgeändert werden: Entfernen Sie den Parameter "-oraw". Der korrekte Eintrag lautet:

lp -s -dprintername

In älteren Versionen des Programms GIMP muß die Kommandozeile von "/usr/bin/lpr -Pprintername -l" abgeändert werden auf

/usr/bin/lpr -Pprintername

Das Feld "PPD File" kann leer gelassen werden. Nur falls Sie das CUPS Drucksystem einsetzen, sollten Sie die passende PPD Datei für Ihren Drucker aus dem Verzeichnis

/usr/share/cups/model/turboprint

Drücken Sie "OK", um das "Setup" zu beendet.

Da GIMP die Grafik beim Drucken aufhellt, sollten Sie noch im Dialog "Adjust Colors" den Regler für Gamma auf 0.55 stellen. Jetzt sind alle Einstellungen korrekt, um mit TurboPrint zu drucken.

Sie können noch die Druckgröße und Position der Grafik auswählen. Verwenden Sie den "Scaling" (Skalieren) Schieberegler zur Änderung der Druckgröße. Die Druckposition kann entweder durch Bewegen des schwarzen Rechtecks im Vorschau-Fenster oder durch Eingabe der Position in den Feldern "Left" (links) und "Top" (oben) geändert werden. Mit "Center Image" zentrieren Sie die Grafik in der Seitenmitte.

Abschließend drücken Sie auf "Print" oder "Print And Save Settings", um zu Drucken, oder einfach nur "Save Settings", um die veränderten Einstellungen abzuspeichern.

Netscape

Der Druck-Dialog wird im "File" Menü aufgerufen, Option "Print...".

In Verbindung mit TurboPrint wählen Sie

Print To: Printer
Print Command: lpr -Pprintername

Die anderen Einstellungen im Dialog können wie gewünscht vorgenommen werden. Stellen Sie aber sicher, daß Sie die richtige Papiergröße gewählt haben.

StarOffice

Setup

Bevor Sie drucken können, müssen Sie erst einen oder mehrere Drucker einrichten.

StarOffice - Desktop

Klicken Sie auf "Printer Setup" im StarOffice Desktop.

StarOffice - Setup Dialog

Wählen Sie "Generic Printer" aus der Liste der verfügbaren Drucker. Rufen Sie "Add new printer" auf - ein neuer Eintrag erscheint in der Liste.

Falls Sie das CUPS Drucksystem verwenden, ist es sinnvoll, stattdessen einen neuen Druckertreiber hinzuzufügen. Klicken Sie auf "Install new driver" und geben Sie bei "Driver Directory - Browse" den Pfad der CUPS PPD-Dateien ein. Dies ist normalerweise

/usr/share/cups/model/turboprint

Wählen Sie dann den passenden Drucker aus und klicken Sie auf "Ok". Der Drucker erscheint nun in der Liste der Druckertreiber von StarOffice. Wählen Sie ihn dort nochmals aus und rufen Sie "Add new printer" auf - ein neuer Eintrag erscheint in der Liste.

Wählen Sie "Connect...", um den folgenden Dialog zu öffnen.

StarOffice - Printer Connect Dialog

Wählen Sie die gewünschte Drucker-Konfiguration aus (z.B. "tp0") und schließen Sie das Fenster wieder mit "OK".

Jetzt rufen Sie "Configure" mit dem "Configure.."-Schalter auf.

StarOffice - Printer Configure Dialog

Voreinstellungen (Default) für Papiergröße und Ausrichtung anwählen. Setzten Sie "Postscript Level" auf "2" und "Color space" auf "Color". Falls Sie das CUPS Drucksystem installiert haben, müssen Sie auch die passende Druckauflösung in DPI wählen. Beenden Sie den Dialog mit "OK". Falls Sie das CUPS Drucksystem installiert haben, müssen Sie auch die passende Druckauflösung wählen.

Abschließend können Sie den Druckernamen mit "Rename" ändern. Schließen Sie jetzt auch den "Printer Setup"-Dialog - die Druckereinstellung ist abgeschlossen.

Drucken

Öffnen Sie den Druck-Dialog im Menü "File" / "Print".

StarOffice - Print Dialog

Wählen Sie Ihren Drucker aus. Unter "Properties..." können Sie die Papiergröße und den Farbmodus auswählen, bei Einsatz von CUPS auch weitere Einstellungen wie Auflösung und Papiersorte. Das war´s! Mit "OK" starten Sie den Ausdruck.

Hinweis: Der Ausdruck benötigt am meisten Rechenzeit, wenn Sie in xtpconfig auf der Menüseite "Printer" den "Color Mode" auf "TrueColor" gesetzt haben, da dann das komplette Dokument in 24 Bit Farbtiefe über Ghostscript berechnet werden muß. Sie können den Ausdruck mit "Black & White" erheblich beschleunigen (allerdings erhalten Sie keine Farben im Ausdruck). Auch mit "256 Colors" oder "Grayscale" erreichen Sie eine merkliche Geschwindigkeitssteigerung.

KDE Anwendungen

Die meisten KDE Anwendungen verwenden einen Standard-Druck-Dialog.

Die verfügbaren Drucker werden mit Ihrem vollständigen Namen (linke Spalte) und der Kurzbezeichnung (rechter Name) angezeigt. Sie müssen nur Ihren Drucker auswählen und sicherstellen, daß die richtige Papiergröße eingestellt ist.

7.3 Drucken über das Netzwerk

Drucken auf einen Drucker-Server

Wenn Sie TurboPrint verwenden, wird die Umrechnung der zu druckenden Datei (z.B. Postscript, PPM, ...) in drucker-spezifische Kommandos (ESC/P oder PCL) immer auf dem Rechner ausgeführt, der den Druck startet.

Aus diesem Grund muß der Drucker-Server eine Druckerwarteschlange anbieten, die keine weitere Umrechnung oder Filterung der Daten mehr vornimmt. Falls die Drucker-Warteschlangen auf dem Drucker-Server mit TurboPrint eingerichtet wurden, sind automatisch auch "raw printer queues" angelegt, die diese Anforderung erfüllen. Diese tragen die Bezeichnung der normalen Druckerkonfiguration mit der Endung "raw". Beispiel: Wenn die Kurzbezeichnung einer TurboPrint Konfiguration "tp0" ist, heißt die entsprechende Drucker-Warteschlange für "Rohdaten" "tp0raw".

Diese raw printer queue des Servers muß in xtpsetup des Client-Rechners ausgewählt werden.

Beispiel für die Einrichtung eines Netzwerk-Druckers in xtpsetup (der Drucker-Server heißt "printerserver", die raw-Drucker-Warteschlange ist "tp0raw"):

xtpsetup - Netzwerk-Drucker Konfiguration

Ist der Drucker-Server ein Windows Rechner, der über SAMBA angesprochen wird, werden die gesendeten Daten immer als "raw" interpretiert. Ein Beispiel für die Konfiguration eines Windows-Netzwerk-Druckers in xtpsetup (der Drucker-Server ist "windowspc", der Drucker am Server wird unter dem Namen "hp" angesprochen):

xtpsetup - Windows Netzwerk-Drucker Konfiguration

Drucken von einem Windows Rechner

Wenn Sie einen Drucker, der an Ihr Linux-System angeschlossen ist, für einen Netzwerk-Rechner freigeben möchten, der unter Windows läuft, muß das SAMBA-Packet auf Ihrem Rechner installiert und gestartet sein. In der SAMBA Konfigurationsdatei muß die Drucker-Warteschlange für den Zugriff über das Netzwerk freigeschaltet sein.

Welche TurboPrint-Druckerkonfiguration steuern Sie über den Windows-Rechner an? Es gibt zwei Möglichkeiten:

  1. Der für den Drucker passende Druckertreiber wurde unter Windows installiert. Auf dem Linux-System müssen die empfangenen Daten nur noch direkt an den Drucker weitergereicht werden. Das erreichen Sie, indem Sie die "raw"-Drucker-Warteschlange auswählen, z.B. tp0raw. Falls auf dem Linux-System das CUPS Drucksystem installiert ist, werden Druckaufträge von Windows-Rechnern normalerweise immer als "raw" interpretiert, d.h. ohne Änderung an den Drucker geschickt. Falls das bei Ihrer Installation nicht klappt, muß die Datei
    /etc/smb.conf
    
    auf dem Linux-Rechner editiert werden. Im Abschnitt für den entsprechenden Drucker ist die Zeile
    print command = lpr -l -r -P%d %s
    
    hinzuzufügen (bzw. die "print command" Zeile entsprechend abzuändern). Dadurch werden Druckaufträge von Windows als schon für den Drucker passende "raw"-Daten interpretiert.

  2. Ein Standard-Postscript-Treiber wird unter Windows ausgewählt. Nun soll TurboPrint auf dem Linux-Rechner die Daten für den Drucker aufbereiten. Wählen Sie also die normale Drucker-Warteschlange, z.B. tp0. Falls auf dem Linux-System das CUPS Drucksystem installiert ist, existieren keine "raw"-Warteschlangen. In diesem Fall muß die Datei
    /etc/smb.conf
    
    auf dem Linux-Rechner editiert werden. Im Abschnitt für den entsprechenden Drucker ist die Zeile
    print command = lpr -r -P%d %s
    
    hinzuzufügen (bzw. die "print command" Zeile entsprechend abzuändern). Dadurch werden Druckaufträge von Windows als Postscript interpretiert.

Next Previous Contents