Version 0.6.2:
- added support for GNU Autotools (Christophe Nowicki)
- the GNU getopt sources are no longer included; msmtp will fall back to short 
  options when getopt_long is not available (Christophe Nowicki)
- fixed a bug in the certificate check/verification code that prevented 
  msmtp from accepting a wildcard in the Common Name (CN) field (this 
  affected only the OpenSSL version of the code)
- wrapped some lines in the man page (example section)
- updated documentation
  
Version 0.6.1:
- free x509_cert in OpenSSL code of tls_cert_check()
- always check x509_subject common name for hostname matching in OpenSSL code
  of tls_cert_check() (like the GnuTLS code does).
- improved CN/hostname matching in OpenSSL code: it is now case insensitive
  and allows the * wildcard as the left-most character in the CN (RFC 2595)
- check for x509_subject == NULL in OpenSSL code of tls_cert_check()
- moved tls_init()/tls_deinit() from smtp_send() to main()
- removed tls dependencies from net.c
- change comments/code/documentation to read GSASL instead of GnuSASL

Version 0.6.0:
- Added GnuTLS/libgcrypt support to tls.c and cram_md5.c
  You can now choose whether you want to use GnuTLS/libgcrypt or OpenSSL 
  for TLS support and CRAM-MD5 authentication (see Makefile).
- Added sanity checks of server certificate when using TLS.
- Added the tls_trust_file command.
  This enables strict verification of the server certificate.
- Added tls_key_file/tls_cert_file commands.
  These commands enable msmtp to send a client certificate to the server if 
  requested.
- Optional support for GSASL. When used, it replaces the built-in
  PLAIN, LOGIN and CRAM-MD5 authentication code and adds support for
  DIGEST-MD5 and NTLM.
- The EHLO response is now taken into account:
  - The STARTTLS command will only be sent if the server supports it
  - If no authentication method was specified, the best one that is supported
    by the server will be chosen.
- Removed the ability to choose the TLS method with the tls command. This was
  not completely implementable with GnuTLS (since it lacks SSLv2 support afaik)
  and is unnecessary anyway. The best method available is automatically chosen.
- Changed configuration file parsing: Now arguments may contain spaces and may
  be enclosed in double quotes (to allow leading or ending blanks in an 
  argument).
- Reorganized Makefile to support the new configuration options (GSASL/GnuTLS).
- Removed unnecessary #includes from cram_md5.c
- Updated documentation

Version 0.5.3:
- Fixed RFC2821 violations in the "MAIL FROM:" and "RCPT TO:" commands.
- Fixed RFC2487 SHOULD-clause violation: Now send EHLO again after
  successful TLS handshake.

Version 0.5.2:
- fixed stupid bugs in base64dec() and cram_md5() that sometimes caused
  CRAM-MD5 authentication to fail.

Version 0.5.1:
- man page corrections and improvements
- improved error messages
- moved msmtp.html to msmtp.1.html

Version 0.5.0:
- Switched from commandline configuration to a configuration file
  (~/.msmtprc). This improves security (no authentication data on the
  commandline) and allows easy setup of multiple accounts.  
  The only options are --help, --version, --file, --account now.

Version 0.4.2:
- Security fix: delete username and password information from the commandline
  after they have been extracted, so that this information is not visible per
  ps / top anymore.
  It is still possible to see the length of the authentication information via
  /proc/pid/cmdline in Linux.
  The real fix is to move all sensitive data into a configuration file. This
  is planned for 0.5.0.
  
Version 0.4.1:
- improved error handling in non-TLS net i/o
- the code that removes the Bcc header was updated to conform to RFC 2822,
  section 2.2.3. It now allows continued Bcc header lines to start with ' ' or
  '\t' (previously only '\t' was allowed).
- properly close TLS connection at the end of smtp_send()
- minor cleanups
- minor man page improvements

Version 0.4.0:
- changed the short version of --keep-bcc to -k (as documented in the man page)
- cleaned up the choice of the authentication method in msmtp.c
- changed tls_start() to use tls_io_error() for SSL_connect() errors
- fixed a segfault bug with failing tls_start() that was introduced in 0.3.1
- added --nostarttls option (Kai)
- updated man page to clarify the use of optional arguments (Kai)

Version 0.3.1:
- code cleanups
- documentation improvements
- --help text improvements
- added instructions on how to find out system specific settings to the 
  Makefile
- changed tls.[ch] to hide OpenSSL specific details.
- improved TLS input/output error reporting
- fixed a minor bug in the error handling of tls_start()
- improved error reporting in smtp_get_response()
- fixed minor off-by-one bug in smtp_put() (the check for the return value of 
  vsnprintf() was wrong). This bug would have been triggered if you used an 
  extremely long username for authentication (longer than ca. 950 characters).

Version 0.3.0:
- remove Bcc header by default
- added --keep-bcc to keep the Bcc header.
- fixed handling of lines beginning with a dot
- added GNU getopt source for systems that don't have it
- added xvasprintf/xasprintf() to xmalloc.c
- cleaned up xmalloc.c
- changed merror.c to use xvasprintf()
- open_socket() improvements (now uses getaddrinfo() for protocol independence
  and portability)
- Makefile changes (support for more platforms)
- documentation updates

Version 0.2.6:
- added support for IPv6
- documentation update

Version 0.2.5:
- fixed handling of optional arguments for short options
- fixed error handling for gethostbyname()
- minor documentation changes
- renamed smtp.[ch] to esmtp.[ch]
- improved error reporting in smtp_auth_plain()

Version 0.2.4:
- minor error message changes
- minor documentation changes
- cleanups in tls.c
- error handling changes and fixes in tls.c
- fixed potential problems reported by NetBSD's lint(1)
- moved choice of secure authentication method from smtp.c to msmtp.c

Version 0.2.3:
- changed behaviour of --auth: does not accept 'none' anymore,
  no argument means choose a *secure* method.
- changed behaviour of --tls: does not accept 'any', 'none'
  anymore, no argument means choose best method available.
- documentation updates and minor changes
- minor Makefile tweaks
- now use die() to exit in case of memory allocation failure 
- minor tls.c cleanups
- fixed stupid minor bug regarding base64dec()

Version 0.2.2:
- minor change to the Makefile
- minor change to the man page
- minor changes to unify error messages
- close connection on errors in smtp_send()

Version 0.2.1:
- support for AUTH PLAIN
- documentation fixes, updates and cleanups.
- fixed memory leak in smtp_auth_login()
- fixed stupid bug regarding base64enc()
- clean up smtp_auth_cram_md5()

Version 0.2.0:
- AUTH CRAM-MD5 support
- new option (--auth) to choose the authentication method
- support for --version and --help if one of them is the only argument
- documentation fixes / improvements
- better error messages
- Makefile fixes

Version 0.1.1:
- documentation updates / fixes
- better error handling in start_tls()
- adjust MAX_SMTP_LINELEN in smtp.c
