Oto niektre z waciwoci qmaila. 

Konfiruguracja:
*  automatycna adaptacja do wariantu UNIXa---nie potrzeba adnej konfiguracji
*  AIX, BSD/OS, FreeBSD, HP/UX, Irix, Linux, OSF/1, SunOS, Solaris, ...
*  automatyczna konfiguracja dla hosta (config, config-fast)
*  szybka instalacja - adnych wielkich decyzji do podjcia

Bezpieczestwo:
*  czysta separacja midzy adresami, plikami i programami
*  minimalizacja kodu pracujcego z setuid root (qmail-queue)
*  minimalizacja kodu roota (qmail-start, qmail-lspawn)
*  piciokierunkowe rozdzielenie --- bezpieczestwo do gbi
*  dodatkowe logowanie jednokierunkowych hashw, caych wiadomoci, itp. ( QUEUE_EXTRA )

Tworzenie wiadomoci (qmail-inject):
*  RFC 822, RFC 1123
*  pene wsparcie dla grup adresw
*  automatyczna konwersja list starego typu do formatu RFC 822 
*  imitacja sendmaila tak aby wszystkie UA dziaay
*  dugo linii nagwka ograniczona tylko pamici
*  maskarada hostw (control/defaulthost)
*  maskarada uytkownikw ($MAILUSER, $MAILHOST)
*  automatyczne tworzenie Mail-Followup-To ($QMAILMFTFILE)

usuga SMTP (qmail-smtpd):
*  RFC 821, RFC 1123, RFC 1651, RFC 1652, RFC 1854
*  czysta 8-bitowo
*  931/1413/ident/TAP callback (tcp-env)
*  kontrola retransmisji---stopuje nieautoryzowane prby (control/rcpthosts)
*  adne interferencji midzy kontrol retransmisji i przesyaniem
*  tcpd---odrzuca poczenia SMTP z podanych hostw
*  automatyczne rozpoznawanie lokalnego IP
*  timeouty dla buforw
*  liczenie przeskokw

Zarzdzanie kolejk (qmail-send):
*  pojedycza obsuga dodawanych wiadomoci
*  limit jednoczesnoci (control/concurrencyremote, control/concurrencylocal)
*  podzia katalogu kolejki---adnego spowalniani po rozroniciu si kolejki
*  kwadratowy mechanizm ponawiania---stare wiadomoci prbowane s coraz rzadziej
*  niezalene mechanizmy ponawiania wysania
*  automatyczne zabezpieczanie kolejki---adnych strat przy padzie systemu
*  automatyczna kontrola dla kadego z odbiorcw
*  automatyczne czyszczenie kolejki (qmail-clean)
*  podgld kolejki (qmail-qread)
*  szczegowa statystyka dostarcze (qmailanalog, dostpny oddzielnie)

Odbicia (qmail-send):
*  wiadomoci o odbiciu QSBMF---odczytywalne przez maszyn/czowieka
*  obsuga HCMSSC---wiadomoci o bdach niezalene od jzyka zgodne z RFC 1893
*  podwjne odbicia wysyane do postmastera

Trasowanie dla domeny (qmail-send):
*  dowolna liczba nazw lokalnego hosta (control/locals)
*  dowolna liczba wirtualnych domen (control/virtualdomains)
*  maski dla domen (control/virtualdomains)
*  konfigurowalna obsuga procenta (control/percenthack)
*  UUCP

spedycja SMTP (qmail-remote):
*  RFC 821, RFC 974, RFC 1123
*  czysta 8-bitowo
*  automatycznie rozpoznawanie wyczonych hostw
*  sztuczne trasowanie---smarthost, localnet, mailertable (control/smtproutes)
*  timeouty dla buforw
*  pasywna kolejka SMTP---idealna dla SLIP/PPP (serialmail, rozprowadzany oddzielnie)

Przesyanie i listy pocztowe (qmail-local):
*  maski adresw (.qmail-default, .qmail-foo-default, etc.)
*  kompatybilno z .forward sendmaila (dot-forward, rozprowadzany oddzielnie)
*  bazy szybkiego przesyania (fastforward, rozprowadzany oddzielnie)
*  kompatybilno z /etc/aliases sendmaila (fastforward/newaliases)
*  waciciele list---automatyczne przekierowywanie odbi, wiadomoci o wakacjach
*  VERP---automatyczne rozpoznawanie odbiorcy dla odbi w listach
*  Delivered-To---zapobieganie ptlom, nawet pomidzy hostami
*  automatyczne zarzdzanie listami (ezmlm, rozprowadzany oddzielnie)

Lokalne dostarczenia (qmail-local):
*  hierarchia adresw kontrolowana przez uytkownika---fred kontroluje fred-cokolwiek
*  obsuga mboxa
*  godne zaufania dostarczanie przez NFS (maildir)
*  dostarczanie programom kontrolowane przez uytkownika: procmail, itp. (qmail-command)
*  opcjonalne powiadamianie o nowej poczcie (qbiff)
*  dodatkowe automatuczne powiadamianie o odbiorze NRUDT (qreceipt)
*  warunkowe filtrowanie (condredirect, bouncesaying)

usuga POP3 (qmail-popup, qmail-pop3d):
*  RFC 1939
*  obsuga UIDL
*  obsuga TOP
*  APOP
*  modularne sprawdzanie hase (checkpassword, rozprowadzany osobno)
